A A A K K K
для людей з порушеннями зору
Волноваське професійно-технічне училище

Тема: Теоретичні відомості по формули та функції.

Дата: 06.11.2020 11:54
Кількість переглядів: 176

Тема уроку: Теоретичні відомості по формули та функції.

Опрацювати лекцію, зробити консект.

Структура формули

Формули– це вирази, по яких виконуються обчислення. Формула завжди починається із знаку дорівнює (=).

Формула може включати функції, посилання на комірки або імена, оператори і константи.

Наприклад, у формулі =СУММ(В2:В8)*30

СУММ() – функція;

В2 і В8 – посилання на комірки;

: (двокрапка) і * (зірочка) – оператори; 30 – константа.

Функції – заздалегідь визначені формули, які виконують обчислення по заданих величинах, що називаються аргументами, і у вказаному порядку. Структура функції: ім'я функції, відкриваюча дужка, список аргументів, розділених крапками з комою, закриваюча дужка. Аргументом функції може бути число, текст, логічне значення, масив, значення помилки, посилання на комірку. Як аргументи використовуються також константи, формули, або функції.

Посилання вказує на комірку або діапазон комірок аркуша, які потрібно використовувати у формулі. Можна задавати посилання на комірки інших листів поточної книги і на інші книги. Посилання на комірки інших книг називаються зв'язками.

Оператором називають знак або символ, що задає тип обчислення у формулі. Існують математичні, логічні оператори, оператори порівняння та посилання.

Константою називають постійне (не обчислюване) значення. Формула і результат обчислення формули не є константами.

Оператори

Арифметичні оператори.

Арифметичні оператори служать для виконання арифметичних операцій, таких як додавання, віднімання, множення. Операції виконуються над числами.

Використовуються наступні арифметичні оператори:

Оператор

Значення

Приклад

+ (знак плюс)

Додавання

A1+A2

– (знак мінус)

Віднімання

A1?A2

Заперечення

?A1

* (зірочка)

Множення

A1*A2

/ (коса риска)

Ділення

A1/A2

% (знак відсотка)

Відсоток

50%

^ (кришка)

Піднесення до ступеня

A1^2

 

 

 

 

 

 

 

 

 

 

Оператори порівняння

Оператори порівняння використовуються для порівняння двох значень. Результатом порівняння є логічне значення: або ІСТИННЕ, або ХИБНЕ.

Оператор

Значення

Приклад

= (знак рівності)

Рівно

(A1=B1)

> (знак більший)

Більше

(A1>B1)

< (знак менший)

Менше

(A1<B1)

>= (знак більше і рівно)

Більше або рівно

(A1>=B1)

<= (знак менше і рівно)

Менше або рівно

(A1<=B1)

<> (знак менший і більший)

Не рівно

(A1<>B1)

 

 

Текстовий оператор конкатенації

Текстовий оператор амперсанд (&) використовується для об'єднання декількох текстових значень.

Оператор

Значення

Приклад

& (амперсанд)

Об'єднання послідовностей знаків в одну послідовність

"Прізвище"&"Ім’я"&"По-

батькові"

Оператори посилань

Оператори посилань використовують для опису посилань на діапазони комірок.

Оператор

Значення

Приклад

: (двокрапка)

Ставиться між посиланнями на першу і останню комірку діапазону

B5:B15

;(крапка з комою)

Оператор об'єднання

B5:B15;D5:D15

(пропуск)

Оператор перетину множин, служить для посилання на загальні комірки двох діапазонів

B7:D7 C6:C8


« повернутися

Код для вставки на сайт

Вхід для адміністратора